一亩三分地论坛

 找回密码
 获取更多干货,去instant注册!

扫码关注一亩三分地公众号
查看: 655|回复: 5
收起左侧

JAVA入门,用什么版本的JDK?

[复制链接] |试试Instant~ |关注本帖
crazyben 发表于 2014-12-24 09:44:48 | 显示全部楼层 |阅读模式

注册一亩三分地论坛,查看更多干货!

您需要 登录 才可以下载或查看,没有帐号?获取更多干货,去instant注册!

x
本帖最后由 crazyben 于 2014-12-24 09:52 编辑

如题。正在使用head first java,教材里用的是JDK5
但是,java.sun.com上都出到JDK7,JDK8了
小白求助,盼解答
完了,32位的win7,如何破?


补充内容 (2014-12-25 09:46):
善用搜索,完美解决
http://jingyan.baidu.com/article/ab69b270d64a572ca6189f5c.html
sirpanzer 发表于 2014-12-24 10:23:48 | 显示全部楼层
就用最新的吧,向下兼容的。有些api会改,但是不多,学习时注意下就好了。。。
而且熟悉JDK(JRE,JVM)也是学习JAVA的一部分么。。。
位数无所谓,oracle提供适合X64\X86的windows、linux等的jdk。。。
回复 支持 反对

使用道具 举报

nathanwang201 发表于 2014-12-24 21:06:23 | 显示全部楼层
本帖最后由 nathanwang201 于 2014-12-24 21:07 编辑

1.7及以上吧,很多开源项目和软件新版本都是要求1.7及以上版本的JDK了.
回复 支持 反对

使用道具 举报

 楼主| crazyben 发表于 2014-12-25 09:45:19 | 显示全部楼层
sirpanzer 发表于 2014-12-24 10:23
就用最新的吧,向下兼容的。有些api会改,但是不多,学习时注意下就好了。。。
而且熟悉JDK(JRE,JVM)也 ...

配制环境什么的好琐碎,小白要吐血了
回复 支持 反对

使用道具 举报

 楼主| crazyben 发表于 2014-12-25 09:45:46 | 显示全部楼层
nathanwang201 发表于 2014-12-24 21:06
1.7及以上吧,很多开源项目和软件新版本都是要求1.7及以上版本的JDK了.

下了个jdk8u
回复 支持 反对

使用道具 举报

dianek 发表于 2016-4-28 07:59:18 | 显示全部楼层
OpenJDK, jdk8u是ubuntu 16.04的标配啊
回复 支持 反对

使用道具 举报

本版积分规则

请点这里访问我们的新网站:一亩三分地Instant.

Instant搜索更强大,不扣积分,内容组织的更好更整洁!目前仍在beta版本,努力完善中!反馈请点这里

关闭

一亩三分地推荐上一条 /5 下一条

手机版|小黑屋|一亩三分地论坛声明 ( 沪ICP备11015994号 )

custom counter

GMT+8, 2016-12-3 22:17

Powered by Discuz! X3

© 2001-2013 Comsenz Inc. Design By HUXTeam

快速回复 返回顶部 返回列表