一亩三分地论坛

 找回密码
 获取更多干货,去instant注册!

扫码关注一亩三分地公众号
查看: 3583|回复: 21
收起左侧

[DataScience] mac上的python问题,附python的一本入门书籍

[复制链接] |试试Instant~ |关注本帖
dertas1993 发表于 2015-7-14 22:11:14 | 显示全部楼层 |阅读模式

注册一亩三分地论坛,查看更多干货!

您需要 登录 才可以下载或查看,没有帐号?获取更多干货,去instant注册!

x

本人搞统计的,最近刚接触的python,有点问题想要问大家,电脑是mac

  • 我知道mac中自带python,我用terminal下载了ipython,然后用了 直接在terminal中使用ipython就把他弄出来了,但是我想问的是i)有没有能直接点开ipython的地方,就像rstudio那样
                                               ii)这个mac自带的python是2.7.9的啊,怎么能自动升级?
                                               iii)pip install  ***下来的package都去哪了,要哭瞎了(我自己应该没有设置过)
             

                                   
    登录/注册后可看大图
  • 我从网上也直接下来了python3.4  默认的idle,我本来想用这个,但发现根本不会下package,我拿terminal下的package这里import他就告诉我没有。
  • 我从网上下了canopy,里面倒是有,但是完全不会用啊,而且那个为什么老连不上。。。那个editor是不是就是想idle一样的东西。。

希望有大牛帮解答。。。非cs的同学想学门语言真是是伤透了,就想不会推倒公式的人学统计,只能学术,不能学道。

.鐣欏璁哄潧-涓浜-涓夊垎鍦

另有一本thinkpython的pdf个人觉得不错放在网盘上大家一起用吧,如果自己买的话我目前就找到了python for data analysis比较好,另有不少r语言的,都是整合好的

baidu pan:dertas1993

           pin:19931209   自取自用

. 涓浜-涓夊垎-鍦帮紝鐙鍙戝竷
yhfyhf 发表于 2015-7-14 22:35:50 | 显示全部楼层
1.
i) ipython是一个shell,直接在终端下用吧...
ii) 可以用homebrew安装 鏉ユ簮涓浜.涓夊垎鍦拌鍧.
iii) mac下默认是/Library/Python/2.7/site-packages,然而你并不需要知道安装在哪,直接import就行啦.1point3acres缃
2. 用pip安装就可以了,python3的package要用pip3.鐣欏璁哄潧-涓浜-涓夊垎鍦
3. 没用过这个,帮不了你啦...
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-14 22:49:19 | 显示全部楼层
本帖最后由 dertas1993 于 2015-7-14 23:13 编辑
yhfyhf 发表于 2015-7-14 22:35
1.
i) ipython是一个shell,直接在终端下用吧.... visit 1point3acres.com for more.
ii) 可以用homebrew安装

先谢谢你的时间!我其实自己都搜过但是还是不理解才到地里找现成的。。。
1 ii)这个就是用brew update 来升级mac自带的python到3么?
2。真的好神奇,明明自己从网上下的3.4是放在application里的,使用你的pip3后,直接import就弄进去了,但是pip3有个问题啊,那个package里的print位置都报了syntax error,是不是还是因为python版本问题?
屏幕快照 2015-07-14 下午10.49.54.png
回复 支持 反对

使用道具 举报

yhfyhf 发表于 2015-7-14 23:12:52 | 显示全部楼层
1) i) 额,我觉得,理论上是可行的,但应该不会有人会去做这个,用ipython就是为了在终端下用吧。而且,我觉得idle才丑爆了啊,从来没用过idle,mac下的terminal是我见过最漂亮的软件哈哈哈哈哈。btw,terminal你可以自己配色。
ii) 不是brew update,直接brew install python3就好了
2)pip3安装的是兼容python3的package。python3的print一定要用括号,python3跟python2的语法有细微差别。
回复 支持 反对

使用道具 举报

larry_cn 发表于 2015-7-14 23:29:28 | 显示全部楼层
额 下的python3.0 是在 /usr/local/bin/ 下面了
楼主 可以 在bash 里面改下 path variable
terminal 直接python的 话是 mac 自带的 可以把 3.0 改成 py3 什么的
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-14 23:36:39 | 显示全部楼层
yhfyhf 发表于 2015-7-14 23:12
1) i) 额,我觉得,理论上是可行的,但应该不会有人会去做这个,用ipython就是为了在终端下用吧。而且,我 ...

soga,我大概都懂了!感觉对于我这样的电脑**,mac里的玄机好多啊,terminal真的是神奇,就可惜不是特懂里面的原理
回复 支持 反对

使用道具 举报

凝香夜雪 发表于 2015-7-15 00:47:09 | 显示全部楼层
lz的baidu pan:dertas1993. 鍥磋鎴戜滑@1point 3 acres
           pin:19931209   自取自用
怎么用啊... 给个分享链接?
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 08:13:29 | 显示全部楼层
凝香夜雪 发表于 2015-7-15 00:47-google 1point3acres
lz的baidu pan:dertas1993
           pin:19931209   自取自用
怎么用啊... 给个分享链接?

就是baidu网盘,你直接输进去就ok
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 09:11:13 | 显示全部楼层
larry_cn 发表于 2015-7-14 23:29
额 下的python3.0 是在 /usr/local/bin/ 下面了
楼主 可以 在bash 里面改下 path variable . 1point 3acres 璁哄潧
terminal 直 ...

哈哈我已经弄好啦~-google 1point3acres
不过你知道这个warning什么意思么. more info on 1point3acres.com
并且。。这个路径很重要么,因为我找不到这个路径的实际位置。。。。
屏幕快照 2015-07-15 上午9.07.39.png
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 11:06:21 | 显示全部楼层
yhfyhf 发表于 2015-7-14 23:12
1) i) 额,我觉得,理论上是可行的,但应该不会有人会去做这个,用ipython就是为了在终端下用吧。而且,我 ...

大牛,还有个小问题,就是有个叫tkinter的包装不进去啊,哪天有空帮看下是啥问题呐~. 1point 3acres 璁哄潧
屏幕快照 2015-07-15 上午11.05.14.png
回复 支持 反对

使用道具 举报

yhfyhf 发表于 2015-7-15 11:13:42 | 显示全部楼层
dertas1993 发表于 2015-7-15 11:06. 1point 3acres 璁哄潧
大牛,还有个小问题,就是有个叫tkinter的包装不进去啊,哪天有空帮看下是啥问题呐~

看这错误信息,应该是tkinter没有兼容python3的版本。。。
回复 支持 反对

使用道具 举报

凝香夜雪 发表于 2015-7-15 11:38:37 | 显示全部楼层
dertas1993 发表于 2015-7-15 08:13
就是baidu网盘,你直接输进去就ok

问题是输入后显示账号或密码错误、、、
回复 支持 反对

使用道具 举报

qzane 发表于 2015-7-15 12:41:22 | 显示全部楼层
tkinter应该是自带的库啊...你直接import试试看,注意在python2.x版本和python3.x版本中很多地方大小写不一样...
另外ide有一个spyder挺好用的,类似rstudio
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 14:02:56 | 显示全部楼层
yhfyhf 发表于 2015-7-15 11:13
看这错误信息,应该是tkinter没有兼容python3的版本。。。

原来这样。。。我看网上说业界都在用3。x了,谢谢你!
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 14:04:46 | 显示全部楼层
凝香夜雪 发表于 2015-7-15 11:38
问题是输入后显示账号或密码错误、、、

我们是不是登陆界面不一样,你看看我这个,我点登陆就进去了
屏幕快照 2015-07-15 下午2.03.53.png
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 14:46:55 | 显示全部楼层
本帖最后由 dertas1993 于 2015-7-15 15:05 编辑

按qzane的提示。。。我发现tkinter是可以直接import的!我下载swampy的时候用的是pip3 install swampy
然而实际里面的书写格式并没有按照3的来,除了大小写外(我改了下大小写发现问题就换掉了,所以应该是改对了),很多print的问题,解决方法未知。
如果有大牛希望一起分享!
(真不知道3的print为神马要变成和2不一样的结果搞的根本不兼容)

.1point3acres缃暂时的解决方案是在terminal那里直接用输ipython,即使用2.7.9版本的mac自带python,问题都ok了
回复 支持 反对

使用道具 举报

xichcen0425 发表于 2015-7-15 17:43:22 | 显示全部楼层
别升级。会哭。

MacBook-Pro:~$ python --version
Python 3.4.3
-google 1point3acres
然后xcode就起不来了。。。
-google 1point3acres
问题如:
将mac OS的python升级到3.4以后,xcode一点运行就崩。。。。如何还原到2.7啊。。。以前的文件夹已删。

http://www.ianisme.com/it/1617.html
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 17:59:48 | 显示全部楼层
本帖最后由 dertas1993 于 2015-7-15 18:00 编辑
yhfyhf 发表于 2015-7-15 11:13
看这错误信息,应该是tkinter没有兼容python3的版本。。。

就是用idle的话,可以新建一个script(点左上角的file->new file),然后写很多程序再一起运行,不是interactive的,也方便修改
可是在terminal那里ms没有这样的script可以用呀~图二里就没有new file这样的东西了,只有interactive的界面。. 鐗涗汉浜戦泦,涓浜╀笁鍒嗗湴
这样terminal不是反而不方便了~
屏幕快照 2015-07-15 下午5.55.17.png
回复 支持 反对

使用道具 举报

 楼主| dertas1993 发表于 2015-7-15 18:01:19 | 显示全部楼层
本帖最后由 dertas1993 于 2015-7-15 18:02 编辑 . 1point 3acres 璁哄潧
yhfyhf 发表于 2015-7-15 11:13
看这错误信息,应该是tkinter没有兼容python3的版本。。。
. 鐣欏鐢宠璁哄潧-涓浜╀笁鍒嗗湴
还有个图,是拿terminal我截下来的~
屏幕快照 2015-07-15 下午6.02.03.png
回复 支持 反对

使用道具 举报

yhfyhf 发表于 2015-7-15 18:23:41 | 显示全部楼层
dertas1993 发表于 2015-7-15 18:01
还有个图,是拿terminal我截下来的~

额。。。随便找个文本编辑器,将文件后缀名改为py,然后python filename.py就行了啊。。。。
回复 支持 反对

使用道具 举报

本版积分规则

请点这里访问我们的新网站:一亩三分地Instant.

Instant搜索更强大,不扣积分,内容组织的更好更整洁!目前仍在beta版本,努力完善中!反馈请点这里

关闭

一亩三分地推荐上一条 /5 下一条

手机版|小黑屋|一亩三分地论坛声明 ( 沪ICP备11015994号 )

custom counter

GMT+8, 2016-12-10 11:24

Powered by Discuz! X3

© 2001-2013 Comsenz Inc. Design By HUXTeam

快速回复 返回顶部 返回列表