一亩三分地

 找回密码 注册账号

扫描二维码登录本站

微信公众号
扫码关注公众号
留学申请公众号
扫码关注留学申请公众号
查看: 576|回复: 9
收起左侧

【求助】难道用2060就跑不了TensorFlow 1吗!

[复制链接] |只看干货 |机器学习
我的人缘0

升级   88.5%


分享帖子到朋友圈
VincentRow | 显示全部楼层 |阅读模式
本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   100% (40)
 
 
0% (0)    👎

注册一亩三分地论坛,查看更多干货!

您需要 登录 才可以下载或查看,没有帐号?注册账号

x
最近在搭深度学习环境,要完成一个课设,需要用tensorflow-gpu 1.15训练模型。我按照tensorflow官网的版本对应安装了CUDA 10.0 和cuDNN 7.4,环境变量添加了,测试tf.test.is_gpu_available()也是通过,但一开始训练的时候就报这个错:
F tensorflow/stream_executor/cuda/cuda_driver.cc:175] Check failed: err == cudaSuccess || err == cudaErrorInvalidValue Unexpected CUDA error: invalid argument

我的gpu是2060,驱动是r456.71. 按理来说高版本驱动应该都能兼容低版本的吧(CUDA10.0要求的是418以上貌似)


就很气啊,我tensorflow-gpu 2.2 的环境搭好了也可以训练模型了,唯独TF 1代的就不行,查遍百度谷歌都没有有效的解决办法,github貌似也没什么人遇到这个问题。。所以最后来地里挣扎一下,希望好心人大佬可以给点建议!谢谢!!有用的建议会加米!


PS 其实之前已经换TF cpu花了几十个小时把模型训练完了,但现在需要摄像头实时识别测试模型,cpu版只能调用核显,画面卡得一匹完全幻灯片,而且due马上到了,仍然不死心才来地里再挣扎一下,实在解决不了就算了吧反正也不会影响我最后的分数了,主要还是心里气不过………………
我的人缘0
本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   96% (417)
 
 
3% (13)    👎
环境变量里CUDA是10.0?看着好像是CUDA版本错误啊。最差的情况,可以临时租个aws应付一下。

评分

参与人数 1大米 +1 收起 理由
VincentRow + 1 给你点个赞!

查看全部评分

回复

使用道具 举报

我的人缘0

升级   88.5%

本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   100% (40)
 
 
0% (0)    👎
pentilm 发表于 2020-10-29 09:53:40
环境变量里CUDA是10.0?看着好像是CUDA版本错误啊。最差的情况,可以临时租个aws应付一下。
环境变量没有错的是10.0,害我这个也不是很大的项目,就不大材小用了。感谢回答~
回复

使用道具 举报

我的人缘0

升级   34%

pliu19 2020-10-30 09:19:09 | 显示全部楼层
本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   95% (44)
 
 
4% (2)    👎
你确定是cuda 10.0 而不是 10.1 吗? 为啥要用1.15啊 直接用 import tensorflow.compat.v1 as tf 不行吗

评分

参与人数 1大米 +1 收起 理由
VincentRow + 1 给你点个赞!

查看全部评分

回复

使用道具 举报

我的人缘0

升级   88.5%

本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   100% (40)
 
 
0% (0)    👎
pliu19 发表于 2020-10-29 18:19:09
你确定是cuda 10.0 而不是 10.1 吗? 为啥要用1.15啊 直接用 import tensorflow.compat.v1 as tf 不行吗
emmm因为这样子会报错说没有tf.contrib,我查过说这是因为tf2已经把这个删了,所以还是没用。
TF官网给出的版本匹配就是1.15 对应 CUDA10,2.2对应CUDA10.1,我自己以前也试过其他的版本甚至还会出现别的报错……🤷🏻‍♂️我也很无奈
回复

使用道具 举报

我的人缘0

升级   20%

boseqc352 2020-10-30 11:59:40 | 显示全部楼层
本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   100% (23)
 
 
0% (0)    👎
运行命令nvidia-smi检查右上角cuda版本
据我所知新版本的nv驱动(456)都是cuda11
tf-gpu对cuda版本要求很严格
回复

使用道具 举报

我的人缘0

升级   88.5%

本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   100% (40)
 
 
0% (0)    👎
boseqc352 发表于 2020-10-29 20:59:40
运行命令nvidia-smi检查右上角cuda版本
据我所知新版本的nv驱动(456)都是cuda11
tf-gpu对cuda版本要求很严格
是的,但我寻思可以向下兼容吧……
回复

使用道具 举报

我的人缘0

升级   27.71%

redhairdragon 2020-10-30 12:21:46 | 显示全部楼层
本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   98% (942)
 
 
1% (17)    👎
cuda 并不向下兼容。。你得再去下个cudatoolkit 10, 然后link到 cuda 10里

评分

参与人数 1大米 +1 收起 理由
VincentRow + 1 给你点个赞!

查看全部评分

回复

使用道具 举报

我的人缘0

升级   20%

boseqc352 2020-10-30 12:24:23 | 显示全部楼层
本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   100% (23)
 
 
0% (0)    👎
VincentRow 发表于 2020-10-30 12:03
是的,但我寻思可以向下兼容吧……

不兼容
10.0和10.1都不兼容,更别说11了

评分

参与人数 1大米 +1 收起 理由
VincentRow + 1 给你点个赞!

查看全部评分

回复

使用道具 举报

我的人缘0

升级   88.5%

 楼主| VincentRow 2020-10-30 13:25:07 | 显示全部楼层
本楼: 👍   0% (0)
 
 
0% (0)   👎
全局: 👍   100% (40)
 
 
0% (0)    👎
UPDATE:问题已解决。实在是心力憔悴一言难尽,虽然最后死马当活马医解决了,但还是感谢各位大侠的建议,已加米!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册账号

本版积分规则

隐私提醒:
■拉群请前往同学同事飞友|拉群结伴版块,其他版块拉群,帖子会被自动删除
■论坛不能删帖,为防止被骚扰甚至人肉,不要公开留微信等联系方式,请以论坛私信方式发送。
■特定版块可以超级匿名:https://tools.1point3acres.com/thread
■其他版块匿名方法:http://www.1point3acres.com/bbs/thread-405991-1-1.html

手机版|||一亩三分地

Powered by Discuz! X3

© 2001-2013 Comsenz Inc. Design By HUXTeam

Some icons made by Freepik from flaticon.com

快速回复 返回顶部 返回列表